[Simnibs-discuss] Simnibs error - could not find tissue probability maps

Axel Thielscher axelt at drcmr.dk
Thu Nov 19 18:15:22 CET 2020

Hi Adrianna,

thank you for providing the detailed information. Which OS version do 
you use?

We will see whether we can replicate it on our test Mac. In case it runs 
fine here, I would likely suggest a zoom meeting so that we can have a 
look at the issue together.

Best regards,


On 11/18/2020 7:31 PM, Adrianna Giuffre wrote:
> Hello
> My name is Adrianna Giuffre - I am a PhD candidate at the University 
> of Calgary.
> I am using SimNIBS for a current modelling project.
> I am having the problems running new head models.
> 1) I am having troubles running the head models for any of my 
> participants - I keep getting an error message saying : (screen shot 
> attached)
> Traceback (most recent call last):
> File 
> "/Users/adam_kirton_imaging/Applications/SimNIBS-3.2/simnibs_env/lib/python3.7/site-packages/simnibs/cli/headreco.py", 
> line 13, in <module>
> main()
> File 
> "/Users/adam_kirton_imaging/Applications/SimNIBS-3.2/simnibs_env/lib/python3.7/site-packages/simnibs/cli/headreco.py", 
> line 10, in main
> headmodel(sys.argv)
> File 
> "/Users/adam_kirton_imaging/Applications/SimNIBS-3.2/simnibs_env/lib/python3.7/site-packages/simnibs/msh/headreco.py", 
> line 265, in headmodel
> raise OSError('Could not find tissue probability maps.\n'
> OSError: Could not find tissue probability maps.
> Probably something went wrong with the Matlab call or SPM
> My participant folder has an "org" folder with the T1.nii and T2.nii 
> in them.
> I have Matlab installed on my computer. I am not sure if it is an 
> error with where SIMNIBS downloads on my computer - it seems to only 
> download under a "user" - as you can see from the screenshot - it is 
> the only application in the application folder. In my generic 
> application folder - simnibs doesn't show up visually - though when I 
> open it through terminal it does. I am not sure if this is why it 
> cannot find the site-packages within simnibs. I also tried changing 
> the permission of the application (chmod options) and did not have any 
> success.
> I also tried installing simnibs on another user on my computer and on 
> another Mac computer and got the same error. I have used simnibs 
> before and have never had this error.
> I have tried to fix this over the last few days and watched the 
> tutorial videos - I can't seem to fix the problem. I updated simnibs 
> to the current version. I also uninstalled it and tried installing it 
> again and am having the same issue. This problem has only occurred 
> using this version. I previously ran 25 head models on the previous 
> version and did not have any issues.
> Attached are all the screen shots of my error messages and the code I 
> am using to run the headmodels.
> mvp1.sh is the script I am using. I tried "headreco all" and headreco 
> all --cat". The headreco_log.html file is also attached.
> I appreciate your time and help!
> Thank you in advance!
> Kind regards,
> Adrianna
> --
> Adrianna Giuffre | PhD Candidate (Neurosciences) | CSEP-CPT
> University of Calgary
> Calgary Pediatric Stroke Program
> Alberta Children’s Hospital
> 28 Oki Drive NW, Calgary, AB, Canada
> T3B6A8
> 403-955-2471
> adrianna.giuffre1 at ucalgary.ca
> Program website: www.perinatalstroke.com <http://www.perinatalstroke.com>
> _______________________________________________
> Simnibs-discuss mailing list
> Simnibs-discuss at drcmr.dk
> https://mailman.drcmr.dk/mailman/listinfo/simnibs-discuss

Dr. Axel Thielscher
Associate Professor
Danish Research Center for Magnetic Resonance
Copenhagen University Hospital Hvidovre
DK-2650 Hvidovre, Denmark
Department of Health Technology
Technical University of Denmark
DK-2800 Kgs. Lyngby

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.drcmr.dk/pipermail/simnibs-discuss/attachments/20201119/c1531992/attachment.html>

More information about the Simnibs-discuss mailing list