[Simnibs-discuss] mri2mesh error

Valerie Nicolson mrsnicolson at gmail.com
Thu May 7 18:48:53 CEST 2020


I am a new simnibs user on a Mac running Catalina 10.15.4. After
installation (and verifying the simnibs gui using ernie) I tried creating a
mesh using mri2mesh using ernie's T1 only

mri2mesh --all ernie org/ernie_T1.nii.g

After many hours and lots of output it crashes. This is the last of the

meshfix subcortical_FS.stl

ERROR- fseek
failed.exiting mri2mesh after error

I checked, and subcortical_FS.stl exists and is definitely longer than 80
(this seems to be the fseek call in io.cpp that is failing). I've also
tried running meshfix on other .stl files and get the same error, so I'm
getting the idea that meshfix is trying to open some other file). Any ideas
of how to fix this or what file might be missing from my installation?


Valerie Cardenas Nicolson
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://mailman.drcmr.dk/pipermail/simnibs-discuss/attachments/20200507/f2eaaaff/attachment.html>

More information about the Simnibs-discuss mailing list